Frame Relay Multicast
When doing multicast in frame relay network, the very important thing we need to take a close look at is RPF check. Since in some types of Frame Relay network, it is not a full mesh topology.
What is RPF?
RPF is used to prevent multicast loop in the network. RPF uses routing table to check whether it prunes the interface or not. When it receives multicast traffic, it checks where the source of multicast traffic is and compare to its routing able and make sure that the received interface and the forwarding interface to the source is the same interface.
For example, if router received the multicast packet on f0/0. It performs RPF check by looking at its routing table to see the forwarding interface back to the multicast source is the f0/0. If it is not, RPF is failed. If it is, RPF check is passed.
In the frame relay Hub and spoke network, RPF check will be failed since the multicast traffic is received from spoke by hub and forward out by hub to another spoke. Therefore we need a tunnel interface to help accomplished this.
Example
Configuration
R1
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay lmi-type ansi
!
interface Serial1/0.1 multipoint
ip address 192.168.1.1 255.255.255.0
ip pim dense-mode
ip igmp join-group 239.1.1.1
ip ospf network point-to-multipoint
snmp trap link-status
frame-relay map ip 192.168.1.2 101 broadcast
frame-relay map ip 192.168.1.3 102 broadcast
no frame-relay inverse-arp
R2
interface Serial1/0
ip address 192.168.1.2 255.255.255.0
ip pim dense-mode
encapsulation frame-relay
ip ospf network point-to-multipoint
serial restart-delay 0
frame-relay map ip 192.168.1.3 202 broadcast
frame-relay map ip 192.168.1.1 202 broadcast
no frame-relay inverse-arp
!
R3
interface Serial1/0
ip address 192.168.1.3 255.255.255.0
ip pim dense-mode
encapsulation frame-relay
ip igmp join-group 239.1.1.1
ip ospf network point-to-multipoint
serial restart-delay 0
frame-relay map ip 192.168.1.2 303 broadcast
frame-relay map ip 192.168.1.1 303 broadcast
no frame-relay inverse-arp
!
R4
A source of 239.1.1.1 multicast group
This configuration will not work in this case since it is a hub and spoke network RPF check is failed. Therefore, we need to configure the tunnel interface between R1 and R3.
Building Tunnel interface
R1
interface Tunnel0
ip address 1.1.1.1 255.255.255.0
ip pim dense-mode
tunnel source Serial1/0.1
tunnel destination 192.168.1.3
R3
interface Tunnel0
ip address 1.1.1.2 255.255.255.0
ip pim dense-mode
tunnel source Serial1/0
tunnel destination 192.168.1.1
Now, multicast traffic is going through tunnel between R1 and R3. To pass the RPF check in R3 routing table should forward packet to source via Tunnel as well. However, R3 uses s1/0 at this time. To make it work, we require to add static multicast route to R3 as follow.
ip mroute 10.10.10.1 255.255.255.255 tunnel0
Then, we pass RPF check and accomplish this task.
No comments:
Post a Comment